{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-54816","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","state":"PUBLISHED","assignerShortName":"Patchstack","dateReserved":"2026-06-16T09:21:46.612Z","datePublished":"2026-06-17T13:37:37.465Z","dateUpdated":"2026-06-17T15:38:43.012Z"},"containers":{"cna":{"providerMetadata":{"orgId":"21595511-bba5-4825-b968-b78d1f9984a3","shortName":"Patchstack","dateUpdated":"2026-06-17T13:37:37.465Z"},"title":"WordPress Advanced Ads plugin <= 2.0.21 - Remote Code Execution (RCE) vulnerability","problemTypes":[{"descriptions":[{"lang":"en","cweId":"CWE-94","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"impacts":[{"capecId":"CAPEC-253","descriptions":[{"lang":"en","value":"CAPEC-253 Remote Code Inclusion"}]}],"affected":[{"vendor":"Monetizemore","product":"Advanced Ads","collectionURL":"https://wordpress.org/plugins","packageName":"advanced-ads","versions":[{"status":"affected","version":"n/a","lessThanOrEqual":"2.0.21","changes":[{"at":"2.0.22","status":"unaffected"}],"versionType":"custom"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"Improper Control of Generation of Code ('Code Injection') vulnerability in Monetizemore Advanced Ads allows Remote Code Inclusion.\n\nThis issue affects Advanced Ads: from n/a through 2.0.21.","supportingMedia":[{"type":"text/html","base64":false,"value":"Improper Control of Generation of Code ('Code Injection') vulnerability in Monetizemore Advanced Ads allows Remote Code Inclusion.<p>This issue affects Advanced Ads: from n/a through 2.0.21.</p>"}]}],"tags":["x_open-source"],"references":[{"url":"https://patchstack.com/database/wordpress/plugin/advanced-ads/vulnerability/wordpress-advanced-ads-plugin-2-0-21-remote-code-execution-rce-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"HIGH","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"HIGH","baseSeverity":"HIGH","baseScore":7.5,"vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"}}],"solutions":[{"lang":"en","value":"Update the WordPress Advanced Ads Plugin to the latest available version (at least 2.0.22).","supportingMedia":[{"type":"text/html","base64":false,"value":"Update the WordPress Advanced Ads Plugin to the latest available version (at least 2.0.22)."}]}],"credits":[{"lang":"en","value":"Nguyen Ba Khanh | Patchstack Bug Bounty Program","user":"00000000-0000-4000-9000-000000000000","type":"finder"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-06-17T15:18:53.764904Z","id":"CVE-2026-54816","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2026-06-17T15:38:43.012Z"}}]}}