{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-48097","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","state":"PUBLISHED","assignerShortName":"GitHub_M","dateReserved":"2026-05-20T18:40:45.834Z","datePublished":"2026-08-07T19:06:22.730Z","dateUpdated":"2026-08-07T19:34:44.269Z"},"containers":{"cna":{"title":"NexTOR_IP_CHANGER has PATH Injection Leading to Arbitrary Command Execution","problemTypes":[{"descriptions":[{"cweId":"CWE-78","lang":"en","description":"CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-476","lang":"en","description":"CWE-476: NULL Pointer Dereference","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"LOCAL","availabilityImpact":"HIGH","baseScore":7.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}}],"references":[{"name":"https://github.com/0x5t4l1n/NexTOR_IP_CHANGER/security/advisories/GHSA-vx6r-vwjq-567w","tags":["x_refsource_CONFIRM"],"url":"https://github.com/0x5t4l1n/NexTOR_IP_CHANGER/security/advisories/GHSA-vx6r-vwjq-567w"},{"name":"https://github.com/0x5t4l1n/NexTOR_IP_CHANGER/releases/tag/v2.0","tags":["x_refsource_MISC"],"url":"https://github.com/0x5t4l1n/NexTOR_IP_CHANGER/releases/tag/v2.0"}],"affected":[{"vendor":"0x5t4l1n","product":"NexTOR_IP_CHANGER","versions":[{"version":"< 2.0.0","status":"affected"}]}],"providerMetadata":{"orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","shortName":"GitHub_M","dateUpdated":"2026-08-07T19:06:22.730Z"},"descriptions":[{"lang":"en","value":"NexTor IP Changer is a command-line tool that leverages the Tor network to periodically rotate a user's IP address. Versions prior to 2.0.0 have a command execution vulnerability due to unsafe use of `shell=True` with commands that rely on executable resolution through the `PATH` environment variable. An attacker controlling the execution environment can place malicious executables such as sudo earlier in the `PATH`, resulting in execution of attacker-controlled code. Version 2.0.0 fixes the issue."}],"source":{"advisory":"GHSA-vx6r-vwjq-567w","discovery":"UNKNOWN"}},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-08-07T19:34:37.377341Z","id":"CVE-2026-48097","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2026-08-07T19:34:44.269Z"}}]}}