{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-120060","assignerOrgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","state":"PUBLISHED","assignerShortName":"PostgreSQL","dateReserved":"2026-10-30T19:25:18.919Z","datePublished":"2026-11-02T19:09:10.912Z","dateUpdated":"2026-11-02T19:43:04.278Z"},"containers":{"cna":{"providerMetadata":{"orgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","shortName":"PostgreSQL","dateUpdated":"2026-11-02T19:09:10.912Z"},"title":"psqlODBC does not validate server-supplied counts and lengths","datePublic":"2026-11-02T00:00:00.000Z","descriptions":[{"lang":"en","value":"psqlODBC trusts counts and lengths in server data in three places. SQLBulkOperations uses a server-supplied row count in a size subtraction that can underflow. SQLStatistics iterates index keys using a server-supplied key count without bounding it to the fixed storage. Bytea octal decoding reads up to two bytes past the end of a truncated escape sequence. A server not trusted under current SSL settings can crash the client or make it read out of bounds. Versions before psqlODBC 18.00.0006 are affected."}],"affected":[{"vendor":"PostgreSQL","product":"psqlODBC","repo":"https://github.com/postgresql-interfaces/psqlodbc","programFiles":["pgapi30.c","results.c","info.c","convert.c"],"programRoutines":[{"name":"PGAPI_BulkOperations"},{"name":"SC_fetch_by_bookmark"},{"name":"PGAPI_Statistics"},{"name":"convert_from_pgbinary"}],"defaultStatus":"unaffected","versions":[{"version":"0","lessThan":"18.00.0006","status":"affected","versionType":"custom"}]}],"problemTypes":[{"descriptions":[{"lang":"en","type":"CWE","cweId":"CWE-125","description":"CWE-125 Out-of-bounds Read"}]},{"descriptions":[{"lang":"en","type":"CWE","cweId":"CWE-191","description":"CWE-191 Integer Underflow (Wrap or Wraparound)"}]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:H","baseScore":5.9,"baseSeverity":"MEDIUM","attackVector":"NETWORK","attackComplexity":"HIGH","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"UNCHANGED","confidentialityImpact":"LOW","integrityImpact":"NONE","availabilityImpact":"HIGH"}}],"workarounds":[{"lang":"en","value":"Connect only to servers authenticated with sslmode=verify-full or an equivalent GSS setting."}],"solutions":[{"lang":"en","value":"Upgrade to psqlODBC 18.00.0006 or later. The row count, the index-key count, and the octal escape length are checked before use."}],"references":[{"url":"https://github.com/postgresql-interfaces/psqlodbc/security/advisories/GHSA-4mfx-cfxx-c877","tags":["vendor-advisory"]}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-120060","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-11-02T19:21:21.052088Z"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2026-11-02T19:43:04.278Z"}}]}}