{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-113687","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","state":"PUBLISHED","assignerShortName":"apache","dateReserved":"2026-10-20T15:05:47.375Z","datePublished":"2026-11-02T13:10:11.700Z","dateUpdated":"2026-11-02T21:05:13.726Z"},"containers":{"cna":{"providerMetadata":{"orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","shortName":"apache","dateUpdated":"2026-11-02T13:10:11.700Z"},"title":"Apache Syncope: RCE via ProcessGroovyMethodsSandbox bypass","problemTypes":[{"descriptions":[{"description":"CWE-653 Improper isolation or compartmentalization","lang":"en","cweId":"CWE-653","type":"CWE"}]}],"source":{"discovery":"UNKNOWN"},"affected":[{"vendor":"Apache Software Foundation","product":"Apache Syncope","packageURL":"pkg:maven/org.apache.syncope.core/syncope-core-spring","versions":[{"status":"affected","version":"3.0.0-M0","lessThanOrEqual":"3.0.16","versionType":"semver"},{"status":"affected","version":"4.0.0-M0","lessThanOrEqual":"4.0.8","versionType":"semver"},{"status":"affected","version":"4.1.0-M0","lessThanOrEqual":"4.1.3","versionType":"semver"}],"defaultStatus":"unaffected","collectionURL":"https://repo.maven.apache.org/maven2","packageName":"org.apache.syncope.core:syncope-core-spring"}],"descriptions":[{"value":"Improper isolation or compartmentalization vulnerability in Apache Syncope.\n\n\n\nAn administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox.\n\n\n\nThis issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3.\n\n\n\nUsers are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.","lang":"en","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>Improper isolation or compartmentalization vulnerability in Apache Syncope.</p><p>An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox.</p><p>This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3.</p><p>Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.</p>"}]}],"references":[{"url":"https://lists.apache.org/thread.html/xxfmworgxt6bf1got05b5pqbb679zjp0","tags":["vendor-advisory"]}],"metrics":[{"other":{"type":"Textual description of severity","content":{"text":"important"}},"scenarios":[{"lang":"en","value":"GENERAL"}]}],"credits":[{"lang":"en","value":"Alex Palinkash","type":"finder"}],"x_generator":{"engine":"Vulnogram 1.0.3"}},"adp":[{"title":"CVE Program Container","references":[{"url":"http://www.openwall.com/lists/oss-security/2026/11/02/10"}],"providerMetadata":{"orgId":"af854a3a-2127-422b-91ae-364da2661108","shortName":"CVE","dateUpdated":"2026-11-02T21:05:13.726Z"}}]}}