{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-107298","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","state":"PUBLISHED","assignerShortName":"GitHub_M","dateReserved":"2026-10-07T15:53:23.587Z","datePublished":"2026-10-08T17:08:22.022Z","dateUpdated":"2026-10-09T11:39:42.593Z"},"containers":{"cna":{"title":"msgpack5: Deeply nested input can exhaust the decoder stack","problemTypes":[{"descriptions":[{"cweId":"CWE-674","lang":"en","description":"CWE-674: Uncontrolled Recursion","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5.3,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"}}],"references":[{"name":"https://github.com/mcollina/msgpack5/security/advisories/GHSA-24ch-f2g6-9hhh","tags":["x_refsource_CONFIRM"],"url":"https://github.com/mcollina/msgpack5/security/advisories/GHSA-24ch-f2g6-9hhh"},{"name":"https://github.com/mcollina/msgpack5/commit/1e2b5874e555dd7c99417f64788a03b0590bb102","tags":["x_refsource_MISC"],"url":"https://github.com/mcollina/msgpack5/commit/1e2b5874e555dd7c99417f64788a03b0590bb102"},{"name":"https://github.com/mcollina/msgpack5/releases/tag/v6.1.0","tags":["x_refsource_MISC"],"url":"https://github.com/mcollina/msgpack5/releases/tag/v6.1.0"}],"affected":[{"vendor":"mcollina","product":"msgpack5","versions":[{"version":"< 6.1.0","status":"affected"}]}],"providerMetadata":{"orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","shortName":"GitHub_M","dateUpdated":"2026-10-08T17:08:22.022Z"},"descriptions":[{"lang":"en","value":"msgpack5 is a msgpack v5 implementation for node.js and the browser. Prior to 6.1.0, the array and map decoding paths have no nesting-depth limit, allowing an attacker who can provide MessagePack input to submit deeply nested containers that exhaust the JavaScript call stack and interrupt a process, worker, or request handler. This issue is fixed in version 6.1.0."}],"source":{"advisory":"GHSA-24ch-f2g6-9hhh","discovery":"UNKNOWN"}},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-09T11:39:21.902387Z","id":"CVE-2026-107298","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2026-10-09T11:39:42.593Z"}}]}}