{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-104308","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","state":"PUBLISHED","assignerShortName":"ibm","dateReserved":"2026-10-01T19:22:55.199Z","datePublished":"2026-10-29T15:18:06.244Z","dateUpdated":"2026-10-29T15:18:06.244Z"},"containers":{"cna":{"providerMetadata":{"orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","shortName":"ibm","dateUpdated":"2026-10-29T15:18:06.244Z"},"title":"Langflow OSS is affected by multiple vulnerabilities","problemTypes":[{"descriptions":[{"lang":"en","cweId":"CWE-78","description":"CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')","type":"CWE"}]}],"affected":[{"vendor":"IBM","product":"Langflow OSS","versions":[{"status":"affected","version":"1.0.0","lessThanOrEqual":"1.12.3","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:langflow_oss:1.0.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:langflow_oss:1.12.3:*:*:*:*:*:*:*"]}],"descriptions":[{"lang":"en","value":"IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to cause a denial of service due to improper neutralization of special elements used in an OS command.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to cause a denial of service due to improper neutralization of special elements used in an OS command.</p>"}]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7293015","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"NONE","availabilityImpact":"LOW","baseSeverity":"MEDIUM","baseScore":4.3,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L"}}],"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ \n\n\n\nFor Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by upgrading <a href=\"https://pypi.org/project/langflow/1.12.4/\" rel=\"nofollow\">Langflow OSS to version 1.12.4.</a></p><p>For Langflow OSS versions 1.0.0 - 1.12.3, follow the <a href=\"https://docs.langflow.org/release-notes\" rel=\"nofollow\">Prepare to upgrade instructions and release-specific configuration changes</a>, including backing up your existing installation, then follow the <a href=\"https://docs.langflow.org/get-started-installation\" rel=\"nofollow\">Langflow OSS installation instructions</a> to install version 1.12.4 and test your flows.</p>"}]}]}}}